Technology

Programming

Post Page Advertisement [Top]

competitive programmingHaker Rank SolutionsPython

Find the Runner-Up Score! - Hacker Rank Solution Python Code

Given the participants' score sheet for your University Sports Day, you are required to find the runner-up score. You are given  scores. Store them in a list and find the score of the runner-up.
Input Format
The first line contains . The second line contains an array   of  integers each separated by a space.
Constraints
Output Format
Print the runner-up score.
Sample Input 0
5
2 3 6 6 5
Sample Output 0
5
Explanation 0
Given list is . The maximum score is , second maximum is . Hence, we print  as the runner-up score.

if __name__ == '__main__':
    n = int(input())
    arr = map(int, input().split())
    arr = arr = list(dict.fromkeys(arr))
    arr.sort(reverse=True)
    print(arr[1])


No comments:

Post a Comment

Bottom Ad [Post Page]

| Designed by Colorlib